Search found 27 matches

by Quasi72
Mon Apr 29, 2024 8:08 am
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Checked, libx265 is not in the list : alex@ghb-debug:~/HandBrake/build/gtk/src$ ldd ghb linux-vdso.so.1 (0x00007ffc0b96a000) libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007b38bfb38000) libgio-2.0.so.0 => /lib/x86_64-linux-gnu/libgio-2.0.so.0 (0x00007b38b2227000) libgobject-2.0.so...
by Quasi72
Fri Apr 26, 2024 6:20 am
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Np, let me know if you want me to test a newer version when it pops up.
by Quasi72
Thu Apr 25, 2024 4:26 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Thread 100 (Thread 0x7246787d8640 (LWP 16063)): #0 __futex_abstimed_wait_common64 (private=0, cancel=true, abstime=0x0, op=393, expected=0, futex_word=0x72470800d2f8) at ./nptl/futex-internal.c:57 #1 __futex_abstimed_wait_common (cancel=true, private=0, abstime=0x0, clockid=0, expected=0, futex_wor...
by Quasi72
Thu Apr 25, 2024 4:24 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

(gdb) thread apply all bt Thread 168 (Thread 0x7246f1feb640 (LWP 15965)): #0 __futex_abstimed_wait_common64 (private=0, cancel=true, abstime=0x0, op=393, expected=0, futex_word=0x724708162d78) at ./nptl/futex-internal.c:57 #1 __futex_abstimed_wait_common (cancel=true, private=0, abstime=0x0, clocki...
by Quasi72
Thu Apr 25, 2024 4:23 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Hey JohnAStebbins, It segfaulted and now i have a coredump, to bad i can't simply attach a .txt to the post so i'm gonna paste everything in here.Did the same commands as the first time and added the encode log, only changed the file names in the log :) Handbrake Version: 20240419140320-c692df6f9-ma...
by Quasi72
Fri Apr 19, 2024 5:04 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

I'm sorry to say that i had a (few) dumb moment(s) today....after noticing there wasn't any core dump i upgraded the system and then restarted the encode so the encode log is also gone. Only thing left is the kernel message : apr 19 03:16:55 ghb-debug2 kernel: ghb[34298]: segfault at 0 ip 000062d5cb...
by Quasi72
Fri Apr 19, 2024 7:13 am
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Got a segfault again but the coredump didn't go as expected....so no file to trace.
by Quasi72
Sat Apr 13, 2024 5:09 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Same packages on Kubuntu, build is a succes now.
I will start encoding tonight and will keep you informed.
by Quasi72
Sat Apr 13, 2024 4:14 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

No problem, if you need anything else just say so. Unfortunately --enable-qsv threw another error... : [100%] Building C object Source/Lib/Encoder/ASM_AVX512/CMakeFiles/ENCODER_ASM_AVX512.dir/highbd_fwd_txfm_AVX512.c.o : gmake[3]: Leaving directory '/home/alex/HandBrake/build/contrib/svt-av1/SVT-AV1...
by Quasi72
Sat Apr 13, 2024 3:36 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Hmmm, i tried to build another ghb from a clone of the first debug machine and the build threw an error : : [71/72] Compiling C object src/ghb.p/hb-backend.c.o : /usr/bin/ld: ./contrib/lib/libavutil.a(hwcontext_drm.o): in function `drm_device_create': : /home/alex/HandBrake/build/contrib/ffmpeg/ffmp...
by Quasi72
Sat Apr 13, 2024 3:03 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Seems logical that it's a x265 codec issue, if it was ghb itself you would get alot more segfault reports. (gdb) print m_curSlice $1 = (x265_10bit::Slice *) 0x7ec632b83fa0 (gdb) print m_curSlice->m_refFrameList[1] $2 = {0x0 <repeats 17 times>} (gdb) print m_curSlice->m_refFrameList[1][0] $3 = (x265_...
by Quasi72
Fri Apr 12, 2024 10:10 am
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Part 2 Thread 65 (Thread 0x7ec718dff640 (LWP 18005)): #0 __futex_abstimed_wait_common64 (private=0, cancel=true, abstime=0x0, op=393, expected=0, futex_word=0x7ec7387c6be4) at ./nptl/futex-internal.c:57 #1 __futex_abstimed_wait_common (cancel=true, private=0, abstime=0x0, clockid=0, expected=0, fute...
by Quasi72
Fri Apr 12, 2024 10:09 am
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

No problem, i didn't find a way to attach a file to the post so here's the output of the gdb commands : I've pasted my preset .json also at the bottom, hope it helps (spread over 2 posts because of message to long)... [Thread debugging using libthread_db enabled] Using host libthread_db library &quo...
by Quasi72
Sun Apr 07, 2024 12:16 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Hi JohnAStebbins, I got a segfault on the machine running the ghb build. [vr apr 5 02:03:39 2024] ghb[18023]: segfault at 0 ip 00005d752ef4a174 sp 00007ec7027fb470 error 4 in ghb[5d752d595000+2b41000] likely on CPU 6 (core 6, socket 0) I have a core dump 5,4Gb but now i'm out of my depth....no idea ...
by Quasi72
Fri Apr 05, 2024 7:26 am
Forum: *nix
Topic: Open source does not work with x11 forwarding
Replies: 3
Views: 297

Re: Open source does not work with x11 forwarding

Hi Saperlot,

No idea how to fix the X11 problem but i'm using a handbrake docker on kubuntu 22.04, this way the entire ghb gui is available from your favorite browser (http, so unsecured).
If security is an issue you can ssh tunnel the port it lives on...
by Quasi72
Thu Apr 04, 2024 7:38 am
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Hey JohnAStebbins, Got another one, unfortunately it's on the machine running the docker so i can't trace anything (i don't know how to...) error code : from dmesg -T : [do apr 4 05:28:37 2024] ghb[1171215]: segfault at 0 ip 0000571aba6894bb sp 0000714b9ab14ac0 error 4 [do apr 4 05:28:37 2024] ghb[1...
by Quasi72
Mon Apr 01, 2024 7:02 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Hey JohnAStebbins,

I will setup a vm just for this on the machine an i'll keep you informed...
by Quasi72
Mon Apr 01, 2024 6:35 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Re: Segfault on kubuntu

Hey mduell,

Never tried from a livecd...but i'm getting this from 2 different machines so what are the odds that both have a hw error ?
Maybe it's related to the codec ? I'm just guessing here...the one thing that strikes me is that i never got this issue when there is no threading on the cpu
by Quasi72
Mon Apr 01, 2024 5:36 pm
Forum: *nix
Topic: Segfault on kubuntu
Replies: 27
Views: 1162

Segfault on kubuntu

Hi guy's, First of all, thx for the great software. I've been using ghb since 1.5.1 and it simply does the things it promises and does it well. However i've also been noticing (and people are reporting it occasionaly) a segfault from time to time. I'm encoding full HD h264 to Full HD h265 10bit no s...
by Quasi72
Sun Mar 12, 2023 10:03 am
Forum: *nix
Topic: Subtitle problem
Replies: 15
Views: 2094

Re: Subtitle problem

Hey Ritsuka,

The latest nightly snapshot has resolved the issue, thx for the quick fix :)
by Quasi72
Wed Feb 15, 2023 4:08 pm
Forum: *nix
Topic: Subtitle problem
Replies: 15
Views: 2094

Re: Subtitle problem

Cool, thx Ritsuka
by Quasi72
Tue Feb 14, 2023 7:19 pm
Forum: *nix
Topic: Subtitle problem
Replies: 15
Views: 2094

Re: Subtitle problem

Seems logical but if the ppa HB has no issue and the flatpak HB encounters this....i feel this is a flatpak issue and not something i can resolve...
I will try a clean install this weekend (try some other OS language/locale) unless someone has some pointers for me ?
by Quasi72
Tue Feb 14, 2023 6:11 pm
Forum: *nix
Topic: Subtitle problem
Replies: 15
Views: 2094

Re: Subtitle problem

Ok, i thought flatpak should use my systems locale....? To be honest i dabble a bit with linux but i'm no way near an experienced user. System locale : LANG=nl_BE.UTF-8 LANGUAGE=nl_BE:nl LC_CTYPE="nl_BE.UTF-8" LC_NUMERIC="nl_BE.UTF-8" LC_TIME="nl_BE.UTF-8" LC_COLLATE=&q...
by Quasi72
Tue Feb 14, 2023 4:31 pm
Forum: *nix
Topic: Subtitle problem
Replies: 15
Views: 2094

Re: Subtitle problem

Hi, I've done some sample encodes, zipped them up and wetransferred them to myself. Download link : https://we.tl/t-iOcuVAdV0N about 70MB and includes a few sample encodes using the 1.5.1 and 1.6.1, when i play this using VLC i get different views of the subs. The test .srt and encode logs are also ...
by Quasi72
Mon Feb 13, 2023 9:05 pm
Forum: *nix
Topic: Subtitle problem
Replies: 15
Views: 2094

Re: Subtitle problem

@mduell : i tried a burn into video and got the same result, subs in the far left bottom corner of the video and annoying shading beneath it so this has nothing to do with the player (unless i misunderstand the burn in to video part). It feels like HB flatpak uses some other way to handle subs (just...