Search found 1816 matches

by BradleyS
Sun May 31, 2020 1:09 pm
Forum: General Questions
Topic: Question regarding CRF
Replies: 4
Views: 37

Re: Question regarding CRF

The section in that article on display sizes and viewing distance attempts to address this issue. Any time a video is enlarged to fill a display, imperfections are magnified, hence the need for higher quality encodes in such situations, as Scott also notes here. I'm open to more clarification on the...
by BradleyS
Wed May 27, 2020 3:51 pm
Forum: Mac
Topic: Wrong file format
Replies: 3
Views: 85

Re: Wrong file format

It sounds like in naming the file in the destination field, you've removed the file extension. Add .mp4 and that should solve the issue.

Of course, this is merely speculation since the required log was not provided.
by BradleyS
Wed May 20, 2020 5:27 pm
Forum: General Questions
Topic: 1080 x 1920 IGVT format
Replies: 2
Views: 100

Re: 1080 x 1920 IGVT format

The Vimeo YouTube HQ 2160p60 4K preset might be a good starting point.
by BradleyS
Tue May 19, 2020 5:01 pm
Forum: Windows
Topic: NVEnc temporal-aq=1 not recognized
Replies: 32
Views: 324

Re: NVEnc temporal-aq=1 not recognized

Great. :) I have an RX 580 I occasionally pop in for testing (purchased used just for that article, believe it or not). Help is always appreciated. The documentation source is at https://github.com/HandBrake/HandBrake-docs. There's a contributing document there but TL;DR it's all written in Markdown...
by BradleyS
Tue May 19, 2020 4:54 pm
Forum: Windows
Topic: NVEnc temporal-aq=1 not recognized
Replies: 32
Views: 324

Re: NVEnc temporal-aq=1 not recognized

Good to know. Indeed, when revising the NVENC docs I used the source code for those options as reference. Naturally, it's not indicated what's available on what hardware, and there are no guards against blowing it up. :/ At some point, I'd like to better document my test setup for the performance ar...
by BradleyS
Tue May 19, 2020 4:42 pm
Forum: Windows
Topic: NVEnc temporal-aq=1 not recognized
Replies: 32
Views: 324

Re: NVEnc temporal-aq=1 not recognized

I just talked with an FFmpeg developer who has indicated there's nothing implemented to prevent or workaround this sort of failure, so we'll just document it's Turing+ only. You might be interested in https://handbrake.fr/docs/en/1.3.0/technical/performance.html, I tried to accomplish some of what y...
by BradleyS
Tue May 19, 2020 4:32 pm
Forum: Windows
Topic: NVEnc temporal-aq=1 not recognized
Replies: 32
Views: 324

Re: NVEnc temporal-aq=1 not recognized

Thanks very much for this. FFmpeg should be handling this better (perhaps there's a patch on master?); in the meantime, I'll get the documentation squared away.
by BradleyS
Tue May 19, 2020 2:52 pm
Forum: Windows
Topic: NVEnc temporal-aq=1 not recognized
Replies: 32
Views: 324

Re: NVEnc temporal-aq=1 not recognized

Yes, but HandBrake isn't using FFmpeg master, but 4.2.2. So the error when using the dash (and the HEVC encoder) is to be expected ( also, HandBrake's documentation is incorrect until we release with a newer FFmpeg :P ). The error when using the underscored needs investigating (though I suspect it'...
by BradleyS
Tue May 19, 2020 1:34 pm
Forum: Windows
Topic: NVEnc temporal-aq=1 not recognized
Replies: 32
Views: 324

Re: NVEnc temporal-aq=1 not recognized

FFmpeg master branch accepts underscore or dash.

The issue I am seeing is the same as:

Code: Select all

 [15:47:32] encavcodecInit: Unknown avcodec option temporal-aq
And related failure using an underscore. I'll have to recheck this when I have time.
by BradleyS
Tue May 19, 2020 7:28 am
Forum: Windows
Topic: NVEnc temporal-aq=1 not recognized
Replies: 32
Views: 324

Re: NVEnc temporal-aq=1 not recognized

Indeed. To be clear I wasn't suggesting using FFmpeg as much as noting that HandBrake does for this purpose, and the option should be available for use. Will investigate.
by BradleyS
Tue May 19, 2020 1:46 am
Forum: Windows
Topic: NVEnc temporal-aq=1 not recognized
Replies: 32
Views: 324

Re: NVEnc temporal-aq=1 not recognized

I am seeing this here as well with a 1080 Ti. Perhaps a bug. It definitely exists in FFmpeg: https://github.com/FFmpeg/FFmpeg/blob/n ... hevc.c#L99
by BradleyS
Sun May 17, 2020 1:39 pm
Forum: Devices and Presets
Topic: Removing motion artifacts
Replies: 6
Views: 194

Re: Removing motion artifacts

Just had a chance to look at this. The artifacts in question are moire. It's possible the pattern on the shirt is tripping up the interlacing detecting to think there's combing that needs removing, and doing so worsens the issue. If you're certain your source is 100% progressive, disabling all inter...
by BradleyS
Sun May 17, 2020 7:37 am
Forum: General Questions
Topic: Why is the default File Extension "M4V" for MP4 video?
Replies: 8
Views: 233

Re: Why is the default File Extension "M4V" for MP4 video?

I say we have no file extensions and use resource forks. :D
by BradleyS
Sun May 17, 2020 7:34 am
Forum: Windows
Topic: Reorder/Delete Chapters
Replies: 1
Views: 96

Re: Reorder/Delete Chapters

My recommendation would be to make an MKV file of the DVD using MakeMKV, then use MKVToolNix to split by chapters into individual files, then use it again to recombine into the order you want, then use HandBrake to encode to MP4. HandBrake can also encode individual chapters, but cannot combine/reor...
by BradleyS
Thu May 14, 2020 6:46 am
Forum: Devices and Presets
Topic: How to choose specific audio tracks
Replies: 3
Views: 124

Re: How to choose specific audio tracks

IIRC the problem is the MXF has 8 individual mono tracks/channels and no way to identify the mapping. You can probably manually specify the mapping using a command line tool like FFmpeg but it will be cumbersome to do. If possible, rendering a stereo only version is probably easiest. You might also ...
by BradleyS
Tue May 12, 2020 7:40 am
Forum: General Questions
Topic: Recommended preset for 1990s home video?
Replies: 2
Views: 155

Re: Recommended preset for 1990s home video?

If you can't tell the difference between HQ 576p25 Surround and the Super HQ version, use the former.

The NLMeans filter with the Tape tune might help improve noisy/grainy recordings.
by BradleyS
Fri May 08, 2020 12:46 pm
Forum: Mac
Topic: 265 Video & Audio Passthrough
Replies: 4
Views: 230

Re: 265 Video & Audio Passthrough

Subler is the sauce.
by BradleyS
Fri May 08, 2020 8:20 am
Forum: Windows
Topic: Can play H.265 but can't encode H.265
Replies: 11
Views: 406

Re: Can play H.265 but can't encode H.265

The first one is indicating your machine doesn't have the Intel QSV hardware encoder. The selected encoder is a software encoder included with HandBrake.

Anyway, it looks like the latest encode worked fine?
by BradleyS
Wed May 06, 2020 7:57 am
Forum: *nix
Topic: problem with Ubuntu 20.04 focal packages: why do handbrake and handbrake-cli conflict with each other?
Replies: 1
Views: 148

Re: problem with Ubuntu 20.04 focal packages: why do handbrake and handbrake-cli conflict with each other?

The PPA package for the GUI is handbrake-gtk. I suspect you're accidentally mixing Ubuntu repo and PPA packages.
by BradleyS
Tue May 05, 2020 1:55 pm
Forum: Windows
Topic: Handbrake-CLI - Invalid preset
Replies: 14
Views: 375

Re: Handbrake-CLI - Invalid preset

JohnAStebbins wrote:
Tue May 05, 2020 1:44 pm
I may have inadvertently busted this.
:oops: :oops: :oops:

I thought about the changes you're probably referencing, but didn't want to point blame...
by BradleyS
Tue May 05, 2020 1:11 pm
Forum: General Questions
Topic: LucasArts Smush Animation Files
Replies: 1
Views: 113

Re: LucasArts Smush Animation Files

HandBrake's focus is to accept a wide variety of inputs and produce only a few types of modern outputs. FFmpeg, which we use to decode the Smush format, does not have a Smush encoder, making it unlikely an open source encoder exists. A cursory Google search reveals none. So it seems your current app...
by BradleyS
Tue May 05, 2020 1:00 pm
Forum: Windows
Topic: Handbrake-CLI - Invalid preset
Replies: 14
Views: 375

Re: Handbrake-CLI - Invalid preset

Interesting, it should work without the full path (category prefix). Will investigate. Glad you got it working with the workaround. :)
by BradleyS
Tue May 05, 2020 2:09 am
Forum: Windows
Topic: Video is stuttering after deinterlacing from 29.97i to 59.94p
Replies: 1
Views: 196

Re: Video is stuttering after deinterlacing from 29.97i to 59.94p

Try setting the frame rate to Same As Source, VFR (variable) on the video tab, and disabling interlace detection on the filters tab. Any of the bob modes should double the frame rate automatically.